LANSA Documentation Roadmap

LANSA Documentation Roadmap

This is a documentation navigation tool. It will guide you through the various LANSA resources based on your role.

Administrator

Developer

Project Manager

Overview of LANSA's guides

What is LANSA? An outline of LANSA's product range

LANSA Glossary of terms used in LANSA's documentation

Conventions used in this document

Edition Date May 5, 2014

© LANSA


1. Administrator

Quick Reference List | A commonly used list of references and resources for LANSA Administrators.
Product List | A product specific list of links for Administrators.
Checklist | Some tips for Administrators and common items to review when acting as Administrator for the LANSA software.


1.1 Administrators Quick Reference List

Following is a list of commonly referenced administration material:

Topic | Visual LANSA | LANSA for iSeries
LANSA System Settings | System Definitions | Review System Settings System Data Areas
Partition Settings | Partitions | Creating or Changing Partition Definitions
Visual LANSA Environment Settings | Environment Settings | Housekeeping and Environment Settings
User Security Settings | User and Security Maintenance | User Access to the LANSA System
Change Management | Change Management | Task Tracking
About LANSA Software Details | Gathering Information About LANSA | Refer to the ABOUT parameter in the LANSA Parameters.
Full RDMLX Partitions | RDML and RDMLX Partition Concepts | If you Enable a Partition for Full RDMLX
Export and Export | Export and Import | Exporting and Importing
Licenses | LANSA Windows License | LANSA for IBM i License

Other Useful Guides for Administrators:

Introduction to LANSA iSeries Concepts | Ø Introduction to LANSA for iSeries Guide
Open System Utilities for LANSA for iSeries | Ø LANSA Open System Utilities Guide
LANSA Application Deployment Tool | Ø LANSA Application Deployment Tool
Deploying Visual LANSA Application On Linux Guide | Ø Deploying Visual LANSA Application On Linux Guide

Return to

1. Administrator


1.2 Administrator Product List

Following is a list of the key Administrator sections for specific LANSA products:

Product

Complete Guide

Key Sections

LANSA Product Licenses

Ø Installing LANSA on IBM i Guide

LANSA for IBM i Licenses

Ø Installing LANSA on Windows Guide

Visual LANSA Windows Licenses

LANSA for iSeries

Ø LANSA for iSeries User Guide

Housekeeping Components of LANSA

Administration Menu

Ø Introduction to LANSA for iSeries Guide

Refer to complete guide as an excellent overview to working with LANSA systems on IBM i .

Ø LANSA Communication Setup Guide

Refer to this guide to set up communications to an IBM i host.

Ø LANSA Open System Utilities Guide

Refer to complete guide for a list of very useful special utilities for IBM i .

Ø Installing LANSA on IBM i Guide

Planning a new LANSA Installation on an IBM i

LANSA for IBM i Only Installation

Planning a new LANSA Installation on an IBM i

Visual LANSA

Ø Visual LANSA Administrator Guide

Refer to complete guide.

Ø Installing LANSA on Windows Guide
  • Planning a Visual LANSA Installation
  • Visual LANSA with LANSA for iSeries System
  • Visual LANSA Independent System
  • Visual LANSA Client Only System

LANSA for the Web

Ø LANSA for the Web Administration

LANSA for the Web Administrator

Ø Installing LANSA on IBM i Guide

Single-tier LANSA for the Web Installation

Single-tier LANSA for the Web Installation (LANSA for iSeries Installed)

Multi-tier LANSA for the Web Installation

Multi-tier LANSA for the Web Installation (LANSA for iSeries Installed)

LANSA for the Web Configuration and Set Up on IBM i

Ø Installing LANSA on Windows Guide
  • Web Function Editor Installation
  • LANSA for the Web Administrator Installation
  • Single-tier LANSA for the Web on Windows Installation
  • LANSA for the Web on Windows - Web Server Only
  • Multi-tier LANSA for the Web on Windows Installation
  • Mixed Multi-Tier LANSA for the Web (Windows/IBM i )
  • LANSA for the Web Deployment Configurations.

LANSA Integrator

Ø LANSA Integrator Guide

JSM Administration

Appendix A: Performance and Tuning

Ø Installing LANSA on IBM i Guide

LANSA Integrator Installation on IBM i

LANSA Integrator Setup and Configuration on IBM i

Ø Installing LANSA on Windows Guide
  • Installing LANSA Integrator on Windows

LANSA Open

Ø LANSA Open Guide

Getting Started

LANSA Client

Ø LANSA Client Administrator Guide

Refer to this guide for installation details and environment configuration.

Return to

1. Administrator


1.3 Administrator Checklist

Following is a checklist of administrator topics:

Topic | Visual LANSA | LANSA for iSeries
Have you reviewed the LANSA System level settings? | System Definitions | Review System Settings System Data Areas
Have you defined the partition level settings? | Partitions | Creating or Changing Partition Definitions
If the partition is multilingual, have you reviewed the language settings? | Language Settings | Partition Multilingual Attributes
Has the partition been enabled for Full RDMLX development? | RDML and RDMLX Partition Concepts | If you Enable a Partition for Full RDMLX
Have you reviewed the environment settings such as locks, languages, messages, etc.? | Environment Settings | System Data Areas
Have you set the LANSA user security for all developers? | User Security and Maintenance | Review User Access to the LANSA System
Have you defined your Change Management strategy and configured LANSA for this strategy? | Change Management | Task Tracking
If you are using Visual LANSA with LANSA for iSeries, have you configured the systems to use the Host Monitor? | Host Monitor | LANSA PC Development
Do you have any existing LANSA applications to import/export into the partitions? | IMPORT | Exporting and Importing
What is the quickest way to find out the details about the installed LANSA software? | Gathering Information About LANSA | LANSA Command (refer to the ABOUT parameter)
Have you checked the LANSA licenses installed? | LANSA Windows License | LANSA IBM i License

Return to

1. Administrator


2. Developer

Quick Reference List | A commonly used list of references and resources for LANSA Developers.
Product List | Product specific list for Developers.
Checklist | Some guidelines for Developers and some common items to review as Developers build LANSA applications.


2.1 Developers Quick Reference List

Following is a list of commonly referenced developer materials:

Product Development | Complete Guide | Key Sections
ALL PRODUCTS | Ø Technical Reference Guide | RDML Commands RDMLX Commands Built-In Functions
 | Ø Application Design Guide | Refer to complete guide.
 | Ø Multilingual Design Guide | Refer to complete guide.
 | Ø SET Guide | Guide organized by product.
 | Ø Tutorial Directory | Tutorials organized by product.
Visual LANSA | Ø Visual LANSA Developer Guide | Creating Fields Creating Databases Creating Applications using Functions Creating Applications using Components
 | Ø Visual LANSA Framework Guide | Refer to complete guide. (This guide will only be available if you installed the Visual LANSA Framework.)
 | Ø Visual LANSA Logical Modeler | Refer to complete guide.
 | Ø Visual LANSA Tutorials | Refer to all tutorials.
LANSA for iSeries | Ø LANSA for iSeries User Guide | Fields Files Processes
 | Ø LANSA iSeries Tutorials | Refer to all tutorials.
LANSA for the Web | Ø LANSA Web Application Modules Guide | Refer to complete guide. WAM Tutorials
LANSA Integrator | Ø LANSA Integrator Guide | JSM Clients JSM HTTP Extensions JSM Services Integrator Tutorials
LANSA Open | Ø LANSA Open Guide | Function Details
LANSA Client | Ø LANSA Client User Guide | Commands Create and Run Queries
 | Ø LANSA Client Tutorials |

Return to

2. Developer


2.2 Developer Product List

Following is a list of the LANSA product guides and key sections for developers:

Product | Complete Guide | Key Sections
Visual LANSA | Ø Visual LANSA Global Guide | This is a global guide containing all Visual LANSA Guides.
 | Ø Visual LANSA Administrator Guide | Host Monitor System Information Maintenance Environment Settings
 | Ø Visual LANSA User Guide | Using the Editor Editing Objects
 | Ø Visual LANSA Developer Guide | Creating Fields Creating Databases Creating Applications using Functions Creating Components
 | Ø Visual LANSA Framework Guide (These links are only available if you have installed the Visual LANSA Framework.) | Building the Application Framework Programming
 | Ø Visual LANSA Logical Modeler | Refer to complete guide.
 | Ø Visual LANSA Tutorials | Refer to all tutorials.
 | Ø SET Guide | Windows Examples
LANSA for iSeries | Ø LANSA for iSeries Global Guide | This is a global guide containing all LANSA for iSeries Guides.
 | Ø Introduction to LANSA for iSeries Global Guide | Refer to complete guide. This guide is a very good starting point for new LANSA IBM i users.
 | Ø LANSA for iSeries User Guide | Fields Files Processes and Functions
 | Ø Technical Reference Guide | This is a reference guide only for both Visual LANSA and LANSA for iSeries.
 | Ø LANSA Open System Utilities Guide | Available Open System Utilities Direct Calling Processes and Functions
 | Ø LANSA iSeries Tutorials | Refer to all tutorials.
 | Ø SET Guide | iSeries (OS/400) Examples
LANSA for the Web | Ø LANSA for the Web Global Guide | This is a global guide containing all Web Guides.
 | Ø LANSA Web Application Modules Guide | Refer to complete guide.
 | Ø LANSA for the Web Administration | Refer to the complete guide if you are developing Web Application Modules (WAMs).
 | Ø SET Guide | Web and Internet Examples
LANSA Integrator | Ø LANSA Integrator Guide | JSM Clients JSM HTTP Extensions JSM Services
 | Ø SET Guide | Integrator/JSM Examples
LANSA Open | Ø LANSA Open Guide | Refer to complete guide.
LANSA Client | Ø LANSA Client User Guide | Commands
 | Ø LANSA Client Administrator Guide | This guide may be helpful if you require details about the environment settings that may impact how queries execute.
 | LANSA Client Tutorials | Refer to all tutorials.

Return to

2. Developer


2.3 Developer Checklist

Following is a checklist of developer topics:

Have you established naming standards & guidelines for LANSA development?

Start with Standards

Object Naming Standards

Do you understand LANSA task tracking and change control?

Change Management

Task Tracking

Do you know the basic steps for approaching LANSA application development?

Application Development

Do you know the basic steps for building the LANSA Repository?

Step 1. Building the Repository

Do you know the different type of LANSA applications that can be created?

Types of LANSA Applications

Do you know how to build Universal Applications?

Creating Applications using Functions

Do you know how to build Component Applications?

Creating Applications using Components

Do you know how to deploy applications?

Refer to 1.1 Administrators Quick Reference List.

Do you know all of the LANSA Field Definition characteristics and features?

Fields

Creating Fields

Do you know all of the LANSA Files characteristics and features?

Files

Creating Application Databases

Do you know the different System Variables?

System & Multilingual Variables

Do you know how to use LANSA Templates?

Application Templates

Do you understand the LANSA RDML Command concepts?

LANSA RDML

RDML Commands

Do you know about the LANSA Built-In Functions?

Built-In Functions by Category

Do you know the LANSA Codes & Formats?

LANSA Formats, Values and Codes

Do you know all of the LANSA Function characteristics?

Creating Applications using Functions

Processes and Functions

Do you know how to code Reports in LANSA?

Producing Report in LANSA

Do you know how to execute LANSA applications?

Executing Applications

Do you know about LANSA Debugging & Tracing?

LANSA Debug mode for IBM i

Debugging Applications for Visual LANSA

Interactive Debugging has extensive interactive debugging facilities to debug applications developed with various Visual LANSA Technologies including:

  • Visual LANSA Components
  • Web Functions
  • WAMs
  • LANSA SuperServer Functions
  • RDML Functions executable as batch jobs using X_RUN

Tracing for LANSA Integrator

Do you know where to find troubleshooting information?

Troubleshooting

Do you know how to design LANSA applications?

Application Design

Application Design Guide

Do you know how to develop LANSA applications for multiple languages?

Multilingual Applications

Do you know where to find a complete list of all shipped LANSA samples and examples?

SET Guide

Sample RDML Programs

Do you know where to find a complete list of all of the LANSA tutorials?

Tutorial Directory

Return to

2. Developer


3. Project Manager

Quick Reference List | Commonly used list of references and resources for LANSA Project Managers.
Product List | A product specific list of topics that are useful for Managers.
Checklist | Some important topic references for LANSA Project Managers.

Project Managers will want to review a variety of information sources as they manage LANSA projects. The Project Manager links focus on high-level overviews of the products and tasks.


3.1 Project Manager Quick Reference List

Following is a list of commonly referenced project manager materials:

Manager Topic | Guide
The installation global guide provides details for installing any of the LANSA products on the IBM i , Windows and Linux platforms. You will be able to locate requirements and planning information to assist in your install. | Ø Installing LANSA Guide
This guide will help you to understand some of the design issues when preparing for LANSA application development. It may provide you with some valuable design insights prior to beginning your first project. | Ø Application Design Guide
This guide will help you understand issues relating to multilingual development projects. It explains basic architecture concepts for multilingual applications and is useful for understanding the impacts of using multiple languages. | Ø Multilingual Application Design Guide
This guide is a very good starting point for new LANSA IBM i users. It is an excellent introduction to using the LANSA for iSeries development environment. | Ø Introduction to LANSA for iSeries Guide
You should use this guide primarily as a reference for LANSA development techniques and to lookup specific topics. | Ø Visual LANSA Developer Guide
This guide provides important concepts for managing the LANSA application environment. It will help you to understand how development can be controlled. | Ø Visual LANSA Administrator Guide
This guide provides some helpful working samples and examples of how LANSA products may be used. You may find valuable design ideas and development approaches in this guide. | Ø SET Guide
This directory lists all LANSA tutorials by product and will help you understand training requirements. | Ø Tutorial Directory

Return to

2. Developer


3.2 Project Manager Product List

Following is a list of the LANSA product guides and key sections for project managers:

Product | Complete Guide | Key Sections
ALL PRODUCTS | Ø Application Design Guide | Refer to this guide before starting to develop your LANSA applications. It provides a wide range of valuable design tips.
 | Ø Multilingual Application Design Guide | Refer to this guide before starting to plan and develop multilingual applications in LANSA.
 | Ø SET Guide | This guide provides some helpful samples and examples of how LANSA products may be used.
 | Ø Tutorial Directory | This directory lists all LANSA tutorials by product and will help you understand and schedule training.
Visual LANSA | Ø Visual LANSA Global Guide | The global guide contains all Visual LANSA Guides. This is a very useful resource if you wish to search for topics specifically about Visual LANSA.
 | Ø Visual LANSA Administrator Guide | Managers may wish to review the Change Management section of this guide.
 | Ø Visual LANSA User Guide | Managers wishing to review Visual LANSA development editor will benefit from the Using the Editor section of this guide.
 | Ø Visual LANSA Developer Guide | All managers should review the Getting Started with LANSA Development and Creating LANSA Applications sections of this guide.
 | Ø Visual LANSA Framework Guide | Introduction provides a high level description of the Visual LANSA Framework.
 | Ø Visual LANSA Logical Modeler | The Introduction provides a description of Logical Modeling concepts and benefits.
 | Ø Visual LANSA Fundamental Tutorials | This guide contains tutorials to teach the fundamentals of Visual LANSA such as the Repository and uses Forms for processing.
 | Ø Developing Windows Applications with a Visual Framework Tutorial | This tutorial introduces the skills needed to develop Windows applications for Windows and Web using the Visual LANSA Framework.
LANSA for iSeries | Ø LANSA for iSeries Global Guide | Global guide contains all iSeries Guides. This is a very useful resource if you wish to search for topics specifically about LANSA for iSeries.
 | Ø Introduction to LANSA for iSeries Guide | This guide is a very good starting point for new LANSA IBM i users. It is an excellent introduction to LANSA for iSeries development. Introduction to the LANSA Repository The LANSA Environment Getting Started with LANSA
 | Ø LANSA for iSeries User Guide | The LANSA Overview section provides a description of the LANSA for iSeries development environment. This guide provides complete documentation for IBM i development and administration.
 | Ø LANSA iSeries Tutorials | This guide includes the complete LANSA for iSeries training.
 | Ø LANSA for Web Global Guide | Global guide contains all Web Guides. This is a very useful resource if you wish to search for topics specifically about LANSA for the Web.
LANSA for the Web | Ø LANSA Web Application Modules Guide | The Introduction to WAMs provides a summary of how to develop LANSA for the Web application using Web Application Modules.
LANSA Integrator | Ø LANSA Integrator Guide | The Introduction provides a description of the LANSA Integrator components and operation.
LANSA Open | Ø LANSA Open Guide | The Introduction provides an overview of how the LANSA Open middleware operates.
LANSA Client | Ø LANSA Client User Guide | The Introduction provides and overview of the LANSA Client features and functions.
 | Ø LANSA Client Tutorials | It may be helpful to complete these tutorials to understand how your business may use LANSA Client.

Return to

2. Developer


3.3 Project Manager Checklist

Following is a checklist of manager topics:

Checklist Items | Related Topics | Complete Guide
Are you familiar with the different LANSA products that make up the LANSA family? | The What is LANSA? section provides a description of all LANSA products. | Ø Installing LANSA on IBM i Guide
Are you familiar with the basic software component definitions? | LANSA Software Definitions and Development and Deployment Options will help you determine the type of LANSA systems and environment is best suited to your project needs. | Ø Installing LANSA on Windows Guide
Are you familiar with the basic Repository-based 4GL development principles and LANSA architecture? | All managers should review the Getting Started with LANSA Development and Creating LANSA Applications sections of this guide. | Ø Visual LANSA Developer Guide
If you are using the LANSA for iSeries development environment, have you reviewed the basic development concepts? | Refer to complete guide. | Ø Introduction to LANSA for iSeries Guide
Have you decide upon a change management approach with the LANSA Administrator? | Change Management | Ø Visual LANSA Administrator Guide
Do you know about the LANSA online training for assisting your development team? | Refer to complete list. | Ø Tutorial Directory
If you need to access the complete LANSA documentation set, use the Global Guide. | Use the search tab to locate the required topic information. | Ø LANSA Global Guide

You should also review the 3.2 Project Manager Product List for each of the LANSA Products being used on your project.

Return to

2. Developer


Overview of LANSA Guides

Guide | Description | Used by?
Ø What's New in this version of LANSA? | This guide summarizes the new features introduced in this version of LANSA. It is a very good starting point. | All
Ø Tips for Using Online Guides | This guide provides some tips for using the online documentation including searching, navigation, printing, etc. | All

The guides fall into these groups:

  • Installation and Deployment
  • LANSA for iSeries
  • Visual LANSA
  • LANSA Integrator and LANSA for the Web
  • LANSA Open and LANSA Client
  • Design and Reference


Installation and Deployment

Guide | Description | Used by?
Ø Installing LANSA on IBM i Guide | This guide has been written for IBM i system administrators or developers who are responsible for installing and maintaining the LANSA development and execution environments. It describes the installation of LANSA software components on an IBM i Server. | Administrators
Ø Installing LANSA on Windows Guide | This guide has been written for Windows system administrators or developers who are responsible for installing and maintaining the LANSA development and execution environments. This guide describes the installation of LANSA software and their components on a Microsoft Windows platform. | Administrators
Ø Installing LANSA on Linux Guide | This guide provides instructions for installing LANSA on a Linux Server. The contents are written for technical support staff and LANSA developers and assume that readers have a solid understanding of the Linux operating system and LANSA. | Administrators
Ø Installing LANSA Communications Setup Guide | This guide provides instructions for installing LANSA Communications Extensions to provide access to TCP/IP (Sockets) as a communications method to an IBM i, Visual LANSA or Linux host. These extensions provide native TCP/IP sockets support to LANSA workstation products by exposing the sockets interface via an APPC interface. | Administrators
Ø Deploying LANSA Applications on Windows | This guide describes the many options and settings required to deploy a Visual LANSA application onto a target PC or execution-only Linux system using the LANSA Application Deployment Tool. | Administrators Developers Managers
Ø Deploying LANSA Application on Linux Guide | This guide provides instructions for planning and deploying Visual LANSA applications on a Linux Server. It is assumed that readers have a solid understanding of the Linux operating system and Visual LANSA. It is also assumed that the application to be ported to Linux already works with a Windows Server. | Administrators Developers Managers
Ø Deployment Check List/Planning Sheet Index for Visual LANSA Framework | This document provides detailed step-by-step instructions for deploying Visual LANSA Framework applications in Windows or Web. The instructions also cover the deployment of RAMP applications. | Administrators


LANSA for iSeries

Guide | Description | Used by?
Ø Introduction to LANSA for iSeries Guide | This guide has been written for new LANSA IBM i developers who are beginning to create their first applications using the LANSA for iSeries development environment. This guide describes the basic components of the IBM i application development environment. | Administrators Developers Managers
Ø LANSA for iSeries User Guide | This guide describes the facilities available with LANSA for iSeries and the LANSA Repository. It describes how to access and how to use these facilities. | Administrators Developers Managers
Ø LANSA for iSeries Tutorials | The LANSA for iSeries Tutorials have been designed to introduce you to the LANSA Repository and the RDML programming language. These tutorials provide a simple introduction to developing applications with LANSA. | Developers
Ø Technical Reference | This guide provides a summary of all LANSA technical rules including RDML & RDMLX commands and Built-In Functions. | Developers
Ø LANSA Open System Utilities Guide | This guide contains technical information about the LANSA Open Systems Utilities that allow you to perform powerful global manipulations of a LANSA system outside many of the normal internal LANSA checks. | Administrators Developers


Visual LANSA

Guide | Description | Used by?
Ø Visual LANSA Administrator Guide | This guide contains the common administration tasks and descriptions of how they are accomplished. It documents all environmental settings for Visual LANSA. | Administrators
Ø Visual LANSA User Guide | This guide contains a description of all IDE menu categories and their options. Guide describes the main parts of the IDE (Repository Browser, Outliner, Detailer, Source Editor, etc.) and how the interface works. It defines the LANSA development environment user interface options. | Developers
Ø Visual LANSA Developer Guide | This guide focuses on how to create applications in LANSA. It is an application programmer's guide. It provides practical techniques for developers to create their applications and assumes that they know how to use the interface (as described in the User Guide). | Developers
Ø Visual LANSA Framework Guide | This guide provides a complete summary for installing and programming with the Visual LANSA Framework. The Framework is an optional extension to LANSA that provides an application framework for designers and developers. The guide includes a set of online tutorials. | Administrators Developers Managers
Ø Ø Rapid Application Modernization Process-TS Guide | This guide provides instructions for using RAMP to modernize 5250-applications. The guide includes a set of of tutorials. The RAMP-TS software supersedes RAMP_NL. The RAMP_NL guide has not been linked to this list. | Developers Administrators Managers
Ø Visual LANSA Logical Modeler | This guide provides instructions for planning and creating a data model using the Visual LANSA Logical Modeler. The contents are written for system analysts and LANSA developers and assumes that readers have a solid understanding of data modeling and are familiar with one or more data modeling methodologies. The guide includes a set of online tutorials. | Developers
Ø Visual LANSA Tutorials | The Visual LANSA Tutorials have been designed to introduce you to the IDE, LANSA Repository and the RDML programming language using forms and functions. These tutorials provide a complete set of exercises to learn about to developing applications with LANSA. | Developers


LANSA Integrator and LANSA for the Web

Guide | Description | Used by?
Ø LANSA Integrator Guide | This guide has been written for developers who will be using the LANSA Integrator, in particular the Java Service Manager, to interact with Java classes (programs). It is assumed that the reader has some knowledge of the target operating system. (for example OS/400, Windows or Linux). The guide includes a set of online tutorials. | Administrators Developers Managers
Ø LANSA Web Application Modules Guide | This guide summarizes LANSA for the Web application development using LANSA Web Application Modules (WAMs). The guide includes a set of online tutorials. | Administrators Developers Managers
Ø LANSA for the Web Administration Guide | This describes the Web Administrator in detail as well as the Web Interactive Debugging facility. If you are using LANSA for the Web in a multi-tier configuration, you will find the set up instructions in this guide. | Administrators Developers


LANSA Open and LANSA Client

Guide

Description

Used by?

Ø LANSA Open Guide

This guide provides a complete summary for installation and programming with LANSA Open. It includes examples for Visual Basic programming.

Administrators

Developers

Managers

Ø LANSA Client User Guide

This guide provides instructions for using LANSA Client. LANSA Client is an easy-to-use query, reporting and charting tool for accessing your corporate data on a Windows, IBM i or Linux machine.

The tutorials provide step-by-step descriptions of the most common uses of LANSA Client and are a good place to start if you are unfamiliar with LANSA Client's features and the best way to use them.

Administrators

Developers

Managers

Ø LANSA Client Administrator Guide

This guide describes the options that can be selected as defaults when using LANSA Client and shows how to create a LANSA Client environment file that includes these defaults.

Administrators

Ø LANSA Open Guide for .NET Developers

This guide contains instructions for using LANSA Open for .NET Version 3. It also contains executable samples and a class reference.

Developers

Ø LANSA Open for .NET Tutorials

This guide contains set of tutorials which show how to use LANSA .Open for .NET Version 3 in Visual Studio. The guide also contains installation instructions and descriptions of shipped sample code.

Developers


Design and Reference

Guide | Description | Used by?
Ø Multilingual Design Guide | This guide provides a description of how LANSA multilingual support is implemented and how to obtain the best results when using it. You should read this guide after you have become familiar with the design and implementation of non-multilingual applications. | Developers Managers
Ø Application Design Guide | The LANSA Application Design Guide provides tips for both experts and novices whether creating or maintaining LANSA applications. This guide should be used before commencing on the design of any LANSA based application. New LANSA users will become familiar with naming standards and operating system and database constraints. | Developers Managers
Ø Technical Reference Guide | This guide provides a summary of all LANSA Repository rules as well as technical details for RDML Commands, RDMLX Commands, Built-In Functions, System Variables, Formats, Values and Codes, Template Commands and Variables and more. | Developers
Ø SET Guide | The SET collection contains hundreds of examples and templates designed to help you create LANSA-based solutions rapidly and effectively. The samples are intended for both LANSA application designers and developers working with any LANSA product. You can optionally install the samples as ready-to-run applications. | Developers


What is LANSA?

LANSA is an integrated family of highly productive design, development and maintenance products for multi-platform host and network applications. This family of products provides an extremely flexible application development environment where a developer can use a single skill set to build and deploy applications for the IBM i, Windows or Internet environments.

LANSA's powerful Repository-based 4GL has enabled developers to quickly deploy applications across computing boundaries and across computing paradigms. A simple recompile can transform a host-centric IBM i application using RPG/ILE into a client/server Windows application using C/C++ or a browser-based Internet application using HTML and IIS Plug-in.

Developer productivity and ease-of-use are LANSA trademarks. For years, developers have enjoyed the benefits of LANSA's Rapid Development and Maintenance Language (RDML) that insulated them from low-level languages and platform complexities. RDML can build IBM i applications, graphical event-driven Windows applications and Web applications. The LANSA Repository provides a centralized application definition and platform independent database architecture. This powerful combination has protected companies' information technology investments for over 10 years.

LANSA was the first IBM i development tool to fully embrace the Internet and Web technology. LANSA for the Web has allowed developers to construct Internet, Intranet and Extranet applications. Today, there are hundreds of thousands of people using LANSA Web-based applications in retail, health care, insurance, manufacturing, government, communications and many other industry sectors.

As an introduction to the LANSA family of products, review the following:

What is LANSA for iSeries?

What is Visual LANSA?

What is Visual LANSA Framework?

What are Web Application Modules (WAMs)

What is Commerce Edition?

What is the LANSA Integrator?

What is LANSA Open?

What are the Open System Utilities for IBM i?

What is LANSA Client?


What is LANSA for iSeries?

LANSA for iSeries is an award winning application development tool originally designed to create applications for IBM i servers. LANSA for iSeries provides a total, integrated environment for modeling, designing, programming, testing, implementing and maintaining application systems. The LANSA applications may execute as host applications, Web-enabled applications or client/server applications.

The LANSA for iSeries development environment greatly increases developer productivity by using LANSA's Repository-based 4GL technology. Developers can rapidly assemble applications using the LANSA RDML (Rapid Maintenance and Development Language). RDML allows the developer to create a platform independent application definition. LANSA's RDML language can be compiled into a number of different languages including RPG/ILE on the IBM i and C/C++ for Windows platforms.

A major component of the LANSA for iSeries software is the LANSA Repository. The LANSA Repository can be used independently of the development aspects of LANSA for iSeries in conjunction with other LANSA products. The LANSA Repository on iSeries can be used as the server for the workstation-based products such as LANSA Client, LANSA SuperServer, LANSA Open and LANSA for the Web. As such, you may be required to install LANSA for iSeries to support one of these other LANSA products.

Ý What is LANSA?


What is Visual LANSA?

Visual LANSA provides a comprehensive Windows-based development environment for building your LANSA Repository and RDML functions. IBM i developers can use Visual LANSA as a power workstation in a distributed development environment with LANSA for iSeries. This allows you to develop both client and server programs using only one set of easy-to-learn skills. You can rapidly edit and debug your RDML using a powerful graphical development environment.

Visual LANSA can be used on a stand-alone workstation or on a workstation that is part of a network configuration. Visual LANSA supports a variety of configurations to support the diverse requirements of your application development environments.

Visual LANSA includes component technology that allows you to develop advanced GUI applications for Windows. These visual components, which you create, are stored in LANSA's Repository along with the fields and files you are using in your applications. Components support a full range of properties, events and methods for building powerful event-driven applications.

With Visual LANSA, your applications can be deployed onto a variety of platforms in flexible, multi-tier combinations that can include IBM i, Windows, Linux, Solaris and more.

Visual LANSA's application environment fully supports LANSA for the Web (including Commerce Edition) and LANSA Integrator. The LANSA Client query and reporting tool can also be used to query your LANSA applications in the Visual LANSA environment.

Ý What is LANSA?


What is Visual LANSA Framework?

Visual LANSA Framework is a framework that helps you design and implement large scale and highly integrated Visual LANSA applications both for Windows and web. You can use the executable framework to very rapidly prototype Visual LANSA application designs without writing a single line of code. You can easily convert your prototype designs into real applications by snapping in your own tailor-made Visual LANSA components.

The Framework is the executable environment that provides the structure and the basic functionality for applications, business objects, commands, menus, etc. It has prototyping and program coding assistants and integrated tutorials that guide you in creating your application.

Ý What is LANSA?


What are Web Application Modules (WAMs)

WAMs are a component-based Web technology used for building applications for the Internet or other networks. WAMs use an XML/XSL technology. They offer the ability to deliver content in multiple formats such as HTML, WML, or XML from a single WAM component.

The LANSA for the Web WAM technology is an extension of the LANSA development environment. If you have Repository and RDML/RDMLX skills, you can apply them to building Web-based applications using WAMs.

Weblets are shipped with the software to provide wizards or building blocks that facilitate the rapid development of HTML browser-based applications. To create your own Weblets, or complex HTML pages, you will need XSL, HTML and JavaScript skills.

The XSL used for transformation of the XML WEBROUTINE document conforms to the standard W3C XSL 1.0 specification.

Refer to the Web Application Module Guide for more information.

Ý What is LANSA?


What is Commerce Edition?

LANSA Commerce Edition is a suite of Business-to-Business (B2B) and Business-to-Consumer (B2C) components that are built on LANSA for the Web. Commerce Edition allows you to rapidly generate e-business applications that integrate existing IBM i, RPG and COBOL applications with the Web and Wireless world.

LANSA Commerce Edition provides an easy, rapid and configurable solution to help you extend your core IBM i applications to both customers and business partners alike. Commerce Edition is a component-based solution that allows you to choose the kinds of functionality you want to deploy on your B2B or B2C Web site.

Commerce Edition is a separately licensed product from LANSA for the Web.

For more details, contact your LANSA distributor.

Ý What is LANSA?


What is the LANSA Integrator?

LANSA Integrator enables integration of Application-to-Application (A2A) and Business-to-Business (B2B) transactions through XML and Java Services. LANSA Integrator allows bi-directional XML and other data formats to be exchanged between you and your trading partners regardless of what platforms they run on. It also enables integration of user-written Java Services with LANSA, RPG and COBOL applications. LANSA Integrator hides the complexities of interfacing XML and Java technologies, letting you concentrate on business requirements.

The LANSA Integrator is a Java service framework that allows you to integrate Java Services with LANSA and 3GL applications. Using the Java Service Manager you can integrate with any system on any platform using your choice of B2B technologies such as SOAP, IBM MQ Series, XML Parsing, XSL Transformation, FTP, HTTP, HTTPS, SMTP, and POP3.

LANSA Integrator can be installed as part of a LANSA system or in a standalone mode.

For more details, refer to the LANSA Integrator Guide.

Ý What is LANSA?


LANSA Composer

LANSA Composer provides a simple but powerful process orchestration capability that allows you to combine transport, transformation and custom business processing with processing Directives that provide conditional, iterative and other capabilities. A complete business process consisting of a number of steps may be defined, executed and managed as a single processing unit of work, without programming.

LANSA Composer provides ready-to-use Activities supporting widely-used transport protocols including:

  • FTP Inbound (file transfer protocol)
  • FTP Outbound (file transfer protocol)
  • HTTP Inbound (hypertext transfer protocol)
  • HTTP Outbound (hypertext transfer protocol)
  • POP3 for inbound e-mail (post office protocol)
  • SMTP for outbound e-mail (simple mail transfer protocol)
  • Inbound and outbound via message brokering systems such as IBM MQ Series

To use these transport Activities with LANSA Composer, you simply need to provide configurations that specify the variable information required to connect or communicate with the other parties involved. There is no programming involved.

Using the supplied transport Activities, you can exchange business information such as orders and invoices with other parties, including external trading partners and internal business units, using agreed standards-based protocols as appropriate for each party.

LANSA Composer includes powerful visual mapping that allows you to define how to map data between disparate formats including:

  • XML documents
  • EDI documents
  • Microsoft Excel 2007 (XLSX) files
  • Text files (for example comma-separated values)
  • Web service functions
  • A wide range of databases, including IBM DB2 Universal Database for iSeries

The maps created with the visual mapping tool can be directly integrated into your business processes along with transport and other Activities.

With the transformation capabilities you can transform business information between external and internal formats as it is received or before it is sent. In this way you can readily extract information from corporate databases to send as, say, XML conforming to a schema agreed with your trading partner. Similarly you can transform in-coming XML documents and write them directly to your corporate database for further processing by your existing applications.

For further information, refer to the LANSA Composer Guide.

Ý What is LANSA?


What is LANSA Open?

LANSA Open is 'middleware' or software that facilitates the high-speed transfer of information and data between

  • PC-based client applications, developed using any of the popular workstation development tools,

and

  • a server (LANSA) on a IBM i, Windows, or Linux platform.

LANSA Open allows non-LANSA application developers to share and reuse LANSA's Repository and RDML technologies. It enables the rapid delivery of high performance client/server applications for the IBM i and other platforms. Developers can provide the Windows interface that users demand while maintaining the security and high performance necessary for mission critical applications. LANSA Open allows developers to use their favorite PC development tool with the speed of LANSA's middleware and the robustness of LANSA server applications.

An integral part of LANSA Open is the LANSA Object Repository, which contains all field and file details including the relevant business rules. This ensures that all PC applications are subjected to the same rigorous security checks, data validation and referential integrity checks as IBM i applications.

When using LANSA Open with LANSA for iSeries, setup tasks, which are outlined in this guide, need to be performed on the IBM i Server.


What are the Open System Utilities for IBM i?

The Open System Utilities facility is a library of utilities that allow experienced developers to manipulate the LANSA environment. These utilities enable global or system level manipulations of a LANSA for iSeries environment.

The types of manipulations the Open System Utilities perform require skill and care to be exercised whenever they are used. Source code and documentation for each utility is provided.

No warranty is expressed or implied in the provision of these utilities.

Some of the facilities provided by these utilities are:

  • High-speed movement of complete partitions between environments and machines.
  • Stripping down of non-development systems (i.e. to run-only) to minimal size.
  • Change of LANSA program and/or data library names.

For details of the specific utilities included, refer to the Open System Utilities Guide.

Ý What is LANSA?


What is LANSA Client?

LANSA Client gives end users GUI access to IBM i or Windows databases with the power and protection of the LANSA Repository and RDML. You can report, chart and query from a single tool with unparalleled ease-of-use, as well as copy data to popular spreadsheets or other PC tools for analysis. Your data is protected with LANSA's file-level security. You can dramatically reduce the application backlog by empowering end users to create their own reports.

When using LANSA Client with LANSA for iSeries, setup tasks, which are outlined in this guide, need to be performed on the IBM i Server. Refer to the LANSA Client User Guide for the set up tasks required on the server.

Ý What is LANSA?


LANSA Glossary of terms

5250 Workstation | A 5250 Workstation is a character-based display device used specifically with IBM i servers.
Access Path | An access path is an IBM i file concept. An access path defines the order in whichrecords are read from an IBM i physical or logical file.
Access Route | An access route is used to describe relationships between LANSA files. It is used by templates, Predetermined Joined Fields and LANSA Client.
Action Bar | An action bar is a style of user application interface. A detailed description can be found in the IBM SAA/CUA guidelines.
Adaptive Server Anywhere | See SQL Anywhere.
AIX | Operating system used by UNIX computers.
API | Application Programming Interface.
Application Repository (LANSA Repository) | The term Repository or Application Repository describes the application specific data entered by a customer, as in "a customer builds a repository for their business application". For example, fields, files, processes and functions are stored in the LANSA Repository. Each LANSA partition can be described as having its own application repository.
APPC | Advanced Peer-to-Peer Communications. A communication protocol used for the IBM i.
Built-In Function | Built-In Function. A standardized interface in LANSA for accessing external programs.
C/C++ | C is programming language. C++ is an object-oriented version on C.
CASE | Computer Aided Software Engineering
CHEN E-R | Chen Entity-Relationship is used in data modeling.
Client | See Visual LANSA Client Only, Local Client Only and Network Client Only.
Commerce Edition | Commerce Edition is a suite of Business-to-Business (B2B) and Business-to-Consumer (B2C) components that are built upon LANSA for the Web.
Common Options | The Common Options are a group of installation settings that are common to more than one product installation. Also see Visual LANSA Options.
Communications Type | The Communications Type specifies the communications methods used by your system when connecting to an IBM i or other server.
Computer Name | The Computer Name is the name assigned to your machine. This name is used as a unique identifier for connections to an IBM i host.
Configuration | A Configuration is used to store a specific group of settings for a LANSA Software installation. From V11.0 you no longer need to switch the current configuration to run a different LANSA installation and this means you could now run multiple post LANSA V10.x installations concurrently.
CUA | Common User Access. CUA is part of IBM's SAA strategy. CUA provides guidelines for the design of the application user interface.
Data/Application Server | The Data/Application Server is the machine used to host the LANSA Repository and application programs.
Data Dictionary | A data dictionary is an object used for storing fields, record formats and file definitions.
Data Model | A data model is a picture or representation of the information in an organization.
Database | A database is a collection of related files.
Data Source | The Data Source contains the tables for the database management system used by the Visual LANSA Repository.
DBCS: | Double Byte Character Set.
Deployment Images | The Deployment Images are a set of deployable versions of the LANSA Environment to support the deployment of LANSA Applications to end-user machines. These images are installed by default with a LANSA development environment.
Development Languages | Development Languages are the languages of the text that the Development Environment displays. For example, all the text on the login dialog is in the development language. You can install multiple languages if you want to be able to switch between them, e.g. French and English. Also see Partition Language.
DLL | Dynamic Link Library.
e-Business Framework Wizard | The e-Business Framework Wizard is a browser-based utility that allows you to quickly and easily customize the presentation of your LANSA Web applications. The e-Business Framework Wizard is installed at the partition level using Partition Initialization.
Enable For Web | In order to develop LANSA for the Web applications in a partition, you must enable the partition for Web development. Use the Enable for Web option when performing partition initialization.
End-user | An end-user executes or uses an application.
English Development Language | The English Development Language option will install English text and resource files. Also see Development Languages.
Entity | An entity is a data modeling term. It refers to a group of elements that belong together and are uniquely identified by a key or groups of keys.
Exporting | Exporting is the term used to describe the movement of information out of a LANSA partition for use in another partition.
Feature | The LANSA software is grouped into products and features. The list of LANSA features that can be installed is based upon the type of installation being performed.
Field | A field, in file terms, refers to a column in a table or a named group of values.
File | A file is a group of records.
French Development Language | The French Development Language option will install French text and resource files. Also see Development Languages.
Function | A function is a group of RDML commands that is compiled and executed by a user to manipulate the database in some way.
GUI | Graphical User Interface. GUI is a term commonly used to describe the Windows environment on personal computers or programmable workstations.
Host Connection Information | The Host Connection Information is used to specify the communications information (LU Name, user name, password, etc.) to allow your system to connect to a Master System.
Host Monitor | The Host Monitor is an integrated feature of the Visual LANSA IDE that connects a Master LANSA for iSeries system and the Slave Visual LANSA system. It is used to transfer data between the LANSA Repositories in the two systems.
HPUX | Operating system used by Hewlett Packard midrange computers.
ILE | Integrated Language Environment. A programming model used on the IBM i.
Importing | Importing is the term used to describe the movement of information into a LANSA partition from another partition.
I/O Module | An I/O Module is also known as an OAM or Object Access Module. It is a program created by LANSA to handle all input/output processing for a LANSA file.
Independent LANSA System | A LANSA System can be described as Independent if there are no other LANSA development systems that depend on the system, i.e. it has no slaves and it is not part of a distributed development model.
Independent Server | An Independent Server install includes an Independent LANSA System using a Server Database.
Independent Workstation | An Independent Workstation install includes an Independent LANSA System using a Workstation Database.
Initialize Database | The Initialization of a database involves the definition of the database files and loading of the current version of the LANSA software definitions. A newly installed LANSA database must be initialized before it can be used.
Integrator Studio | The LANSA Integrator Studio is an integrated set of applications including the SOAP Wizards, Visual XML Wizard, the Property Editor, XML Editor and XSL Compiler. Also see LANSA Integrator.
Internet | The Internet is a worldwide network of computers. Also referred to as the World Wide Web.
Internet Explorer | Internet Explorer (IE) is a Web browser that is shipped with the Windows operating system. You must use an IE browser for accessing the information on the LANSA CD-ROMs.
Intranet | An Intranet is an internal computer network using TCP/IP protocol.
IIS | Internet Information Services (IIS) is a Windows component for Web publishing. It is an installable feature shipped with the Windows 2000 operating system and later versions.
IIS Plug-in | The LANSA for the Web IIS Plug-in is an ISAPI-based Web serving technology that can be used to deploy LANSA applications using the Microsoft IIS Web Server. The IIS Plug-in is the component used to build the link between the Web Server and the Data/Application Server.
IBM i Language Options | The IBM i Language Options allow you to configure settings associated with the translation of data transferred between the IBM i and the workstation.
Japanese Development Language | The Japanese Development Language option will install Japanese text and resource files. Also see Development Languages.
Java Runtime Environment (JRE) | A Java Runtime Environment is required in order to support the execution of Java objects on a platform. The JRE includes the Java Virtual Machine (JVM) that executes the Java code. The JRE can be downloaded from the Web.
Java Service Manager (Server) | The LANSA Integrator Java Service Manager (JSM) allows developers to integrate Java programs with their existing LANSA or 3GL applications. The Java Service Manager provides a standardized interface for calling Java classes using Java service programs. Also see JSM Administrator, JSM Direct and JSM Instance.
Java Service Manager Proxy (Server) | The LANSA Integrator Java Service Manager Proxy server allows a proxy server to redirect the JSM server requests.
Java Servlet | The LANSA for the Web Java Servlet is a Java-based Web serving technology that can be used to deploy LANSA applications using a Java enabled Web Server such as WebSphere. The Java Servlet is the component used to build the link between the Web Server and the Data/Application Server.
JSM Administrator | The LANSA Integrator JSM Administrator is part of the JSM Server software that is used to set up and configure the JSM Server.
JSM Direct | The LANSA Integrator JSM Direct is part of the JSM Server software that supports the HTTP services.
JSM Instance | The LANSA Integrator JSM Instance is part of the JSM Server software that supports the Java Service instances.
LANSA | LANSA is an integrated family of highly productive design, development and maintenance products for multi-platform host and network applications.
LANSA/AD | LANSA Application Development tool. Now called LANSA for iSeries.
LANSA Client | LANSA Client is a PC-based, graphical query and reporting tool for accessing IBM i or Windows databases with the power and protection of the LANSA Repository and RDML.
LANSA Database | The LANSA Database consists of a group of files that support the LANSA System Definition data and the Application Repository data.
LANSA for iSeries | LANSA for iSeries allows you to rapidly develop online, batch and reporting applications for IBM i servers. LANSA's active object Repository and powerful RDML programming language combine to create a highly productive integrated development environment.
LANSA for the Web | LANSA for the Web allows you to build Web applications quickly and easily. It is an extension of the core LANSA integrated development environment (either Visual LANSA or LANSA for iSeries). LANSA for the Web applications can be deployed across a number of combinations of platforms including the IBM i, Windows, UNIX and Linux.
LANSA for the Web Utilities | The LANSA for the Web Utilities include the Web Administrator and Web Function Editor.
LANSA Integrator | LANSA Integrator enables integration of Application-to-Application (A2A) and Business-to-Business (B2B) transactions through XML and Java Services.
LANSA Open | LANSA Open (previously called LANSA/Server) is 'middleware' or software that facilitates the high-speed transfer of information and data between PC-based client applications and a server using the LANSA Repository.
LANSA Open Core Files | The LANSA Open Core Files must always be installed when LANSA Open is installed.
LANSA Repository | See Application Repository.
LANSA System | A LANSA System consists of the LANSA Software, the LANSA System Definition data, and the Application Repository data. A LANSA System can be a LANSA for iSeries system or a Visual LANSA System. A LANSA System can be defined as a Master LANSA System or Slave LANSA System.
LANSA System Definition | The LANSA System Definition describes the system specific data that is used by the LANSA software to define and support the development environment. The RDML commands, messages, templates, BIFs, are part of the system definition as well as information such as system owners, user authorities, machine date formats, etc. A LANSA System Definition is primarily identified by its version number. Parts of the System Definition data can be customized by the customer to create a specific development environment.
LANSA Web Site | The LANSA Web site is located at www.lansa.com. If you are not already familiar with this Web site, you will find that it contains information about such items as product releases, support desk tips and techniques, courses available, support contact details, demonstrations etc.
Local Client Only | This installation requires a Visual LANSA Server Installation. (The Server installation can be either a Slave or an Independent installation.) The Local Client Install includes a copy of the LANSA software on the local machine. The C/C++ compiler is optional. The local LANSA software accesses the Application Repository on the server. Also see Network Client Only.
Local Database | A Local Database is a database that is accessed by a single user and is stored on the same machine as the software that accesses the database.
Local Data Directory | The Local Data Directory is the directory where Visual LANSA puts temporary files. For example, the list of objects selected in the Work with Processes window.
Logical File | A logical file is a view of data in a physical file. It is used as a means of sorting or accessing data in a different order.
Logical Models | A logical model or conceptual model is a type of data model that describes data at a high level in user or business terms.
Master LANSA System | A Master LANSA System is identified by its ability to maintain its LANSA System Definition data. The Master System Definition data is loaded when a system is installed or upgraded. A Master LANSA System does not use a host monitor. (Note: In V10.0 and later, LANSA for iSeries system is always a Master LANSA System. Visual LANSA Master LANSA Systems are independent.)
Master LU Name | The Master Logical Unit (LU) Name is the name of the Master System server. For example, a server may be named as APPN.MYAS400 or MYAS400 for the server.
Master Repository | The Master Repository is the name given to the Repository that is located in the Master LANSA System.
Microsoft Visual/C++ compiler | This compiler (V7.0) is shipped on the LANSA Windows Software CD and it is the default compiler used for the C code generated by LANSA.
Network Client Only | This installation requires a Visual LANSA Server Installation. (The Server installation can be either a Slave or an Independent installation.) The LANSA software on the Server is executed by the Network Client Workstation (using shortcuts installed in a local folder) as well as sharing the Server database. Some of the LANSA software must still be installed locally (e.g. Visual Modeler) and some is optionally installed locally (e.g. Microsoft Compiler). All LANSA options are dictated by the server. The LANSA install reads the windows registry on the server and copies it to the local registry. This term replaces the Network Workstation install. Also see Local Client Only.
Network Workstation | This term is no longer used. See Network Client Only.
node | An entry in a tree view.
OAM | Object Access Module. Also known as an I/O Module. It is a program created by LANSA to handle all input/output processing for a LANSA file.
ODBC | Open Database Communications. A Microsoft-based standard for accessing databases.
OLE | Object Linking and Embedding. A Microsoft standard for linking objects together.
OOUI | Object-Oriented User Interface.
OS/400 | Operating System of the IBM i.
Parent/Child | Parent/child is a type of relationship used to describe entities in a data model.
Partition | A Partition is a means of dividing up a LANSA system. Each partition is completely separate from other partitions. Generally partitions will be used to separate classes of users from one another.
Partition Initialization | Partition Initialization allows you to specify how the Visual LANSA System partitions should be set up. You can specify the information and applications loaded into the partition.
Partition Language | Partition Language is the language of the LANSA repository. It is the language of the text that you assign to LANSA objects. For example, field description. Also see Development Language.
PC | Personal Computer.
Personnel System Demonstration | The Personnel System Demonstration includes examples for Visual LANSA and LANSA for the Web. This system is also used by all training materials shipped on the LANSA Windows product CD-ROM.
Physical File | A physical file is a type of file that stores data.
Physical Model | A physical or low-level model is a type of data model that describes data in terms of physical files and how the information is stored in the computer.
PJF | Predetermined Join Field. A special type of virtual field used for accessing information in other files.
Process | A process in LANSA is a group of related user tasks or functions.
RDML | RDML stands for Rapid Maintenance and Development Language. It is the programming language used by LANSA.
RDMLX | Full RDMLX refers to an optional extended set of capabilities and syntax for the LANSA repository and RDML language that enable and support a number of new features in LANSA V11.0. This includes new data types, a relaxation of language limitations and an enhanced language syntax as well as the new Web Application Modules (WAMs).
Record | A record is used to describe a file. It is a row of data.
Record Format | A record format is the name given to the identifier associated with a group of fields in a file.
Relationship | A relationship is a data modeling term. It refers to the characteristics of two entities whereby the information in one entity allows you to access information in the other.
Repository | A central location for storing information.
RFI (Remote Function Invocation) | The LANSA Integrator RFI is middleware that makes remote integration as easy as coding to a local object. It allows developers to write to local objects that automatically reflect changes to remote host objects with all network communications automated.
RLTB | Right Left Top Bottom.
Root Directory | The Root Directory is used to define the location where the LANSA software will be installed.
RPG | RPG is a programming language used on the IBM i.
SAA/CUA | Systems Application Architecture/Common User Access. SAA is a software approach created by IBM to provide consistency across software systems and systems architecture.
Server Database | A Server Database is a database that is accessed by one or more users and is stored on a server that is accessed using a network. This server on which the database is located may or may not contain the LANSA software. That is, the server can be dedicated as a database server or it can also be used by a LANSA developer.
Server Install | An install is classified as a Visual LANSA Server when the LANSA software is installed on the machine and it uses a Server Database. The Server Database may be accessed by one or more Visual LANSA Clients. Also, the LANSA software and the Server Database may be accessed by one or more Visual LANSA Network installations.
SEU | Source Edit Utility. SEU is the name given to the IBM software used to edit source files.
Slave LANSA System | A Slave LANSA System is not able to maintain the LANSA System Definition data. It receives its system definition from a Master LANSA System. It is dependent upon the Master LANSA System. The System Definitions must be updated whenever a change has been made to the Master System. A Slave LANSA System may use a host monitor.
Slave Repository | The Slave Repository is the name given to the Repository that is located in the Slave LANSA System.
Slave Server | A Slave Server install includes a Slave LANSA System using a Server Database. This term replaces the Windows Server install.
Slave Workstation | A Slave Workstation install includes a Slave LANSA System using a Workstation Database. This term replaces the Standalone Workstation install.
SQL | Structured Query Language. A language used for database access.
SQL Anywhere™ | The SQL Anywhere (also known as Adaptive Server Anywhere) database is shipped on the LANSA Windows Software CD and can be installed if a data source cannot be located.
SQL Anywhere Deployable Images | The SQL Anywhere Deployable Images provides database support for deployed LANSA applications. These images are only required if the deployed LANSA applications use the SQL Anywhere database.
Standalone Workstation | This term is no longer used. See Slave Workstation.
TCP/IP | Transmission Communication Protocol / Internet Protocol is a standard communication protocol used by the Internet.
Template | A template or application template is a "program" which generates RDML functions based on a question and answer session with the developer.
Thin Client | A computing model that minimizes code on the client PC and relies heavily on a "fat server" where the majority of code resides.
TIMI | Technology Independent Machine Interface. An approach used by IBM to make the hardware and software layers independent.
TISI | Technology Independent Software Interface. An approach used by LANSA to make the application software and operating system platform layers independent.
Translation Tables | The Translation Tables are used by LANSA Open when a non-English version of the software is required. Also see LANSA Open.
Upgrade | The software Upgrade option is used to load the latest version of the LANSA software to replace an older version of the software.
User Agent | The LANSA Integrator User Agent is a Java-based tool, that allows file upload to a JSM HTTP Service or MQ-Series based function. Also see LANSA Integrator.
Utilities | LANSA supplies a number of programs that are labelled "Utilities". For example, the Web Function Editor and Web Administrator.
Validation Checks | Validation checks are rules that can be associated with a field or a file.
Virtual Field | A virtual field is a field used with LANSA files. Its value is derived from other fields in a LANSA database. The field is not stored in the file.
Visual LANSA | Visual LANSA is an extremely flexible application development environment where you can use a single skill set to build and deploy applications for IBM i, Windows or Internet environments. LANSA's active object Repository and powerful RDML programming language combine to create a highly productive development environment. Visual LANSA acts as the core integrated development environment (IDE) on Windows that is used to support LANSA development.
Visual LANSA Client Only | A Client Only installation uses a Visual LANSA Server system installed on a Windows Server. Also see Local Client Only and Network Client Only.
Visual LANSA Core Files | The Visual LANSA Core Files must always be installed when Visual LANSA is installed.
Visual LANSA Framework | The Visual LANSA Framework is a framework that helps you design and implement large scale and highly integrated Visual LANSA applications. It is an executable environment that provides the structure and the basic functionality for applications, business objects, commands, menus etc. for both Windows and the Web.
Visual LANSA Independent Server Installation | This installation includes a Master Visual LANSA System using a Server Database. In V11.0, the Visual LANSA System has no slaves.
Visual LANSA Independent Workstation Installation | This installation includes a Master Visual LANSA System using a Workstation Database. In V11.0, the Visual LANSA System has no slaves.
Visual LANSA Options | The Visual LANSA Options are a group of installation settings that are specific to the Visual LANSA installation. Also see Common Options.
Visual LANSA Slave Server Installation | This installation includes a Slave Visual LANSA System using a Server Database. In V11.0, the Master System is a LANSA for iSeries System.
Visual LANSA Slave Workstation Installation | This installation includes a Slave Visual LANSA System using a Workstation Database. In V11.0, the Master System is a LANSA for iSeries System.
Web Administrator | The LANSA for the Web Administrator is used to configure the LANSA for the Web software on the Web Server and the Data/Application Server.
Web Application Module | LANSA for the Web component-based web development model. Also known as WAM.
Web Function | LANSA for the Web function-based web development model.
Web Function Editor | The LANSA for the Web Function Editor is a tool that allows developers to build Web components and edit the LANSA HTML pages stored on the Data/Application Server.
Web Images | The Web Images are a default set of image files used by LANSA for the Web.
Web Server | The Web Server is the machine used to host the Web Serving software. Also see Data/Application Server, IIS Plug-in and Java Servlet.
WebSphere™ | WebSphere is Integration and application infrastructure software from IBM for the IBM i, Windows, and other platforms. This includes Web serving software.
Windows | Windows is a graphical operating system interface produced by Microsoft. For information on currently supported versions, refer to the Supported Platforms document on LANSA's web site.
Windows NT/2000 Server Install | This term is no longer used. See Slave Server.
Workstation | Workstation is another name used for a programmable device which has been attached
Workstation Database | A Workstation Database is a database that is accessed by a single user and is stored on the same machine as the software that accesses the database.
Workstation Install | An install is classified as a Visual LANSA Workstation when it contains a complete LANSA System, i.e. it has the LANSA software, LANSA System Definition data and Application Repository data on a single machine and the LANSA System is not accessed by any Visual LANSA Clients.


Conventions Used in this Document

  • Whenever a link appears as follows, Ø Tips Guide, clicking on this link will open the complete guide in a new window.
  • Whenever a link appears as follows, Tips for using the LANSA Online Documentation, it will open the content in the current help window.
  • To open a guide in a new window for the currently displayed text, you can use the Contents (blue book) toolbar. For example, if you click on the link to Navigation, and then press the blue book icon (i.e. Contents) in the Navigation page's toolbar, the complete Tips Guide will be opened so that you can search this guide or review other related topics.
  • Remember that you can search in the main Global Guide to find topics across all LANSA guides. You can sort the results of a search by guide.
    You can also limit the search to a group of guides using their own global guide. For example, the Web Global Guide will allow you to limit a search to the guides related to LANSA for the Web development only.
    From any online guide page, you can use the blue book icon to open that page's guide in a separate guide instance.


Disclaimer

While every effort has been made to ensure that the information in the LANSA documentation is accurate. In no event shall LANSA be liable for any damages arising from its use.

LANSA MAKES NO WARRANTIES, EXPRESSED OR IMPLIED.

Copyright and trademark information

© LANSA. "LANSA" is a trade name and registered trademark of LANSA in the United States of America, Australia, the United Kingdom and other countries. All rights reserved.

The following are some companies which require attribution:

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the United States, other countries, or both. Microsoft, Windows, .NET and the Windows logo are trademarks of Microsoft Corporation in the United States, other countries, or both.

Other company, product, and service names may be trademarks or service marks of others.

This material may contain other proprietary notices and copyright information, the terms of which must be observed and followed.